太噁心了– rubygems安裝gem需要使用代理服務器了

換了一台電腦,想用rubygems重新安裝rails,但一直遇到各種如問題:

sudo gem install -v=2.3.9 rails
Password:
ERROR:  Could not find a valid gem 'rails' (= 2.3.9) in any repository
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    too many connection resets (http://production.s3.rubygems.org/latest_specs.4.8.gz)

ERROR: While executing gem ... (Gem::DependencyError)
  Unable to resolve dependencies: rails requires activesupport (= 3.0.5), actionpack (= 3.0.5), activerecord (= 3.0.5), activeresource (= 3.0.5), actionmailer (= 3.0.5), railties (= 3.0.5), bundler (~> 1.0)

google了半天(期間google中短NNN次),才明天了現在使用rubygems 安裝gem也得開代理了。。。

要使用加了代理的命令:

sudo gem install rails -p http://127.0.0.1:8118

現在rubygems好像只支持http代理。 如果你使用的是socks代理,可以通過Privoxy(支持linux和mac)這個軟件來搞一個http代理 通道, 詳細參看這個教程

轉載請註明: 轉自船長日誌, 本文鏈接地址: http://www.cslog.cn/Content/g-f-w-ni-ma-de/zh-hant/

此條目發表在 Ruby on Rails 分類目錄,貼了 , , , 標籤。將固定鏈接加入收藏夾。

太噁心了– rubygems安裝gem需要使用代理服務器了》有 1 條評論

  1. wlon 說:

    @huacnlee 弄了個鏡像,http://ruby.taobao.org/.

發表評論

電子郵件地址不會被公開。 必填項已用 * 標註

*

您可以使用這些 HTML 標籤和屬性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>