mysqlnd cannot connect to MySQL 4.1+ using old authentication

用PHP5.3.2安装UCenter时遇到 mysqlnd cannot connect to MySQL 4.1+ using old authentication 错误. 类似的错误在安装mediawiki时也遇到过.

这是由于mysql数据库还使用旧的验证方式的结果. 解决方法其实很简单, 重新设置一下用户密码就可以了:

SET PASSWORD FOR 'root'@'localhost' = PASSWORD('新密码');

转载请注明: 转自船长日志, 本文链接地址: http://www.cslog.cn/Content/mysqlnd-cannot-connect/

此条目发表在 站长文档 分类目录,贴了 , 标签。将固定链接加入收藏夹。

发表评论

电子邮件地址不会被公开。 必填项已用 * 标注

*

您可以使用这些 HTML 标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>