在leopard上安装php

怎样在苹果leopard上安装php语言环境? 其实不用安装. 因为leopard已经默认安装了php5. 但默认设置下apache没有装载php组件, 所在不能使用. 要使用php时, 要先将它启动, 方法如下:
1.打开 /etc/apache2/httpd.conf 文件
2.找到

#LoadModule php5_module libexec/apache2/libphp5.so

将前面的注解符#去除, 变成

LoadModule php5_module libexec/apache2/libphp5.so

保存文件
3.重启apache

sudo apachectl restart

现在可以在leopard上使用php5了.

附:

apache的默认根目录:
/Library/WebServer/Documents/
可以在 /etc/apache2/httpd.conf 文件中修改.

用来显示php环境的语句:

<?php phpinfo(); ?>


php.ini文件:
/etc 目录下有一个php.ini.default文件. 复制并改名为php.ini文件:

sudo cp /etc/php.ini.default /etc/php.ini

(修改后重启apache才能生效)

在php.ini文件中找到
mysql.default_socket =
可以修改mysql socket位置, 如:

mysql.default_socket = /tmp/mysql.sock

转载请注明: 转自船长日志, 本文链接地址: http://www.cslog.cn/Content/leopard-php/

此条目发表在 信息处理, 站长文档 分类目录,贴了 , 标签。将固定链接加入收藏夹。

在leopard上安装php》有 2 条评论

  1. 老套 说:

    其实 个人认为 使用 XAMPP 比较不错

  2. 卯时下雨 说:

    leopard已经安装了, 不用再安装xampp了.

发表评论

电子邮件地址不会被公开。 必填项已用 * 标注

*

您可以使用这些 HTML 标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>