太恶心了– rubygems安装gem需要使用代理服务器了

换了一台电脑,想用rubygems重新安装rails,但一直遇到各种如问题:

sudo gem install -v=2.3.9 rails
Password:
ERROR:  Could not find a valid gem 'rails' (= 2.3.9) in any repository
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    too many connection resets (http://production.s3.rubygems.org/latest_specs.4.8.gz)

ERROR: While executing gem ... (Gem::DependencyError)
  Unable to resolve dependencies: rails requires activesupport (= 3.0.5), actionpack (= 3.0.5), activerecord (= 3.0.5), activeresource (= 3.0.5), actionmailer (= 3.0.5), railties (= 3.0.5), bundler (~> 1.0)

google了半天(期间google中短NNN次),才明天了现在使用rubygems 安装gem也得开代理了。。。

要使用加了代理的命令:

sudo gem install rails -p http://127.0.0.1:8118

现在rubygems好像只支持http代理。 如果你使用的是socks代理,可以通过Privoxy(支持linux和mac)这个软件来搞一个http代理 通道, 详细参看这个教程

转载请注明: 转自船长日志, 本文链接地址: http://www.cslog.cn/Content/g-f-w-ni-ma-de/

此条目发表在 Ruby on Rails 分类目录,贴了 , , , 标签。将固定链接加入收藏夹。

太恶心了– rubygems安装gem需要使用代理服务器了》有 1 条评论

  1. wlon 说:

    @huacnlee 弄了个镜像,http://ruby.taobao.org/.

wlon 进行回复 取消回复

电子邮件地址不会被公开。 必填项已用 * 标注

*

您可以使用这些 HTML 标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>